Home / Over ons / Nieuws / Nieuws / Help, mijn plugin geeft aan dat ik een verouderde PHP versie gebruik!

Help, mijn plugin geeft aan dat ik een verouderde PHP versie gebruik!

19 mei 2015 - 00:00u - 4 minuten leestijd

Op onze Service Desk ontvangen wij met enige regelmaat de vraag waarom enkele servers nog op PHP 5.3.x draaien en niet op de recentere PHP 5.5.x of 5.6.x. Wij scheppen graag duidelijkheid. Daarom vertellen we in dit artikel wat over de release cycle van PHP en waarom wij verschillende PHP versies draaien.

Release cycle van PHP

PHP brengt regelmatig nieuwe versies uit en werkt met een bepaalde “release cycle”. Je kunt dit vergelijken met de levensloop van een pak melk, deze wordt op een bepaalde datum geproduceerd en na de houdbaarheid datum is het niet meer verstandig deze te nuttigen.

Je wilt eigenlijk nooit met een “x.y.0” versie werken. dat heeft als voornaamste reden dat er in deze versies nog wel eens wat bugs ontdekt worden. Over het algemeen wachten veel providers daarom even voordat ze een nieuwe versie van PHP aanbieden. Vervolgens is de support periode van PHP erg kort. Ongeveer een jaar mainstream met nog maximaal een jaar daarna voor security updates.

Release cycle PHP

Meer informatie:
http://php.net/supported-versions.php
http://php.net/eol.php

Updaten van PHP niet zomaar “gepiept”

Eigenlijk moet je dus iedere twee jaar een volledig nieuwe PHP implementatie doen. Dit kost ontzettend veel tijd om dit secuur te doen.

Los van dit constateren wij ook dat een relatief groot deel van onze gebruikers een verouderd CMS en/of plugins gebruiken. Het “out of the blue” upgraden kan in dat geval indirect voor problemen zorgen omdat het gebruikte CMS en/of plugins niet overweg kan met de nieuwere PHP versie.

Zo lossen wij dit op

Om dit op te lossen, werken wij met Ubuntu Linux. Op dit moment vooral versies 12LTS en 14LTS.
Die LTS staat voor Long Time Support. Dat betekent dat ze vanaf release alle software 5 jaar lang onderhouden.

  • Bij de 12LTS (uit 2012) met PHP 5.3.10 is dat dus tot medio 2017. Zelfs als PHP zelf die versie niet meer onderhoudt.
  • De 14LTS (uit 2014) heeft PHP 5.5.9 en is onze huidige versie die wij uitrollen sinds zomer 2014. Daarop zit support tot medio 2019 ondanks dat PHP daar medio 2016 geen enkele ondersteuning meer op biedt.

Tot slot worden alle nieuwere servers al met PHP 5.5.x opgeleverd en is hierop de mogelijkheid beschikbaar om terug te gaan naar PHP 5.3.x. Servers die vóór zomer 2014 zijn opgeleverd draaien dus op PHP 5.3.x.

Ik draai nu op PHP 5.3.x maar mijn software vereist PHP 5.5.x of hoger

Sommige software pakketten of plugins kunnen niet overweg met PHP 5.3.x. Akeeba, een veelgebruikte component binnen Joomla geeft bijvoorbeeld de volgende melding:

You are using an obsolete PHP version
Your site is running on PHP 5.3.10-1ubuntu3.17 which has stopped receiving security updates since donderdag 14 augustus 2014. Using this on a live site is dangerous: unpatched security issues can get your site hacked. Moreover, we will only support obsolete versions of PHP for nine months since their end-of-life date. Therefore we will discontinue support for your PHP version on donderdag 14 mei 2015. We strongly advise you to ask your host to upgrade your site to PHP 5.5 or later.

Indien je op PHP 5.3.x draait en je wilt upgraden naar PHP 5.5.x dan kan dit gelukkig vrij soepel. Het enige wat je hiervoor te doen is ons een e-mail te sturen naar servicedesk@realhosting.nl, wij doen de rest.

Nog verdere vragen?

Mocht je nog verdere vragen hebben over dit artikel, neem dan contact met ons op met servicedesk@realhosting.nl.

Dave Marketing manager

Dave is Marketing manager bij RealHosting. Hij verzorgt de (online) marketing en is betrokken bij nieuwe productontwikkelingen.

dave@realhosting.nl - 088-7508918

web-monitoring-ok